W32.Bagle brutta bestiaccia

Aggiornato al 18-04-2009

fix wifi per XP ——– fix wifi per Vista

L’ho beccato e non sò neanche come ho fatto, forse era da tempo che era in circolo nei segnali binari del mio pc.

Mi sono accorto che l’antivirus spariva e alcuni programmi mi davano noie. Connessione caduta. Mah…

Riavvio, caricamento di Windows Xp… paf! di nuovo al boot… e così in loop.. NOOO!!!!

Niente, la procedura è la solita, stacca l’hd (avg da ubuntu ha rilevato la punta dell’iceberg), attaccalo ad un altro pc, scansioni su scansioni elimina le chiavi del registro (collegandole in remoto).

Riattacco l’HD all’interno del mio desktop e il problema non è risolto, continua a loopare.

L’unica cosa che ha risolto è stato fare il boot del cd di windows, entrare nella console di ripristino e digitare

“bootcfg /rebuild”

questo comandino mi ha creato un boot alternativo a quello preesistente e tutto si è avviato da favola.

Non sò se ho preso una versione migliorata del rootkit / virus Bagle, però a giudicare dalle varie guide per la sua eliminazione nessuno ha avuto problemi di avvio dell’OS.

La guida che ho seguito è stata quella postata sul forum di HW upgrade (non sono andato oltre la prima pagina).

Fatto sta che fra tutte le chiavi di registro che inquina, va a toccare il servizio di xp che gestisce le connessioni wifi.

Ho scovato i danni causati da Bagle alla connessione Wifi che permangono dopo che lo si è debellato.

Ho raccolto tutto in questo file (SOLO PER XP – AL FONDO C’è L’AGGIORNAMENTO PER VISTA)

fix wifi bagle by redirete.zip

basta avviare le modifiche del registro e riavviare. Con me ha funzionato. Avessi avuto io una minifix come questa invece di dover aprire il registro e fare tutto a mano sarei stato felice.

SE AVETE DOMANDE, SE SIETE RIUSCITI A RISOLVERE IL PROBLEMA, SE NON SIETE RIUSCITI
SCRIVETEMI UN COMMENTO! SALVERENTE INOLTRE UNA LONTRA SVEDESE E REINOLTRATE QUESTO ARTICOLO A 10 AMICI ALTRIMENTI LA VOSTRA BISBISBISNONNA MORIRA’ DI VECCHIAIA!

Aggiornamento 12-6-08

Un commentatore mi/ci fa notare, i problemi correlati a Bagle possono essere vari e non trattati, anche perchè le varianti di questa “bestiaccia” pare continuino a fioccare indisturbate.

Per rispondere al problema delle cartelle nascoste (sia per vista che per xp), ho fatto una ricerca e la cosa è trattata su Megalab.it . Il redattore “ste_95” ha postato File Nascosti.rar contenente un file di registro che dovrebbe risolvere questo disguido provocato dalla bestiaccia. Il codice torna e i commenti a quel post pure, quindi consiglio di tentare la cosa. Colgo l’occasione per elogiare ste_95 che è arrivato addirittura ad autoinfettare il suo sistema (immagino con un sanbox virtuale o con la virtualizzazione totale) per individuare le modifiche del virus. Vi auguro di risolvere.

Aggiornamento 30-10-08

Mi scuso per quelli di voi che hanno chiesto informazioni riguardo alla rimozione su vista, non ho avuto molto tempo per indagare e non essendo il mio sistema operativo, preferivo fare dei test.

Ho cambiato il link ai files di registro per la soluzione ai file nascosti.  Per sicurezza ho rihostato il file per non inciampare in un brokenlink come spesso succede. Ci sono anche le soluzioni per vista.

Per la riattivazione del wifi per windows vista. consiglio di eseguire (dopo aver rimosso il rootkit) la riattivazione manuale dei vari servizi. In questo link è presente una specifica dei servizi che in generale devono essere riattivati. Mi spiace di non potervi fornire un file pronto per la riattivazione di servizi, quando potrò vedrò di lavorarci. Nel frattempo mamma google è sempre pronta a dar consiglio.

Aggiornamento 28-11-0 – Il mio file di registro per vista pare non funzionasse.

Aggiornamento 28-12-08 Gianniedp ha gentilmente trovato una soluzione per rispristinare i servizi wifi sotto vista, ho creato il file che potete scaricare qui

Dovete scusarmi ma non ho molto tempo per seguire il blog post.

Aggiornamento 18-04-09

I virus tendono a modificarsi nel tempo (più propriamente qualcuno li modifica), di conseguenza le procedure variano e questo post per quanto con piccoli aggiornamenti ha più di un anno, che nel campo dell’informatica è un eternità.

L’aggiornamento è solo per segnalare una guida che, come Alessio ci fa notare, è  aggiornata a risolvere il problema con il nostro amico Bagle

Guida alla disinfezione per Bagle / Mitglieder by xcdegasp

Aggiornamento 27-1-2011

Mamma mia quanto scrivo male!! Forse è la prima volta che lo rileggo integralmente dal 2008.  Ho corretto qualche errore, ma lo stile è brrr… irrecuperabile.
Grazie di tutti i ringraziamenti, è un piacere essere stato utile.

Se trovate utile questo articolo, diventate fan del blog su Facebook.

 

 

Annunci
Questa voce è stata pubblicata in Tecnologia e contrassegnata con , , , , , , , , , , , , , , , , , . Contrassegna il permalink.

115 risposte a W32.Bagle brutta bestiaccia

  1. Roberto ha detto:

    Grazie mille!!!!!
    Era successo anche a me e grazie alla dritta è tutto OK!!

  2. Ros ha detto:

    Grazie… avevo fatto una stupidata anch’io

  3. PREXURE ha detto:

    Ho scoperto anche io Mr.Bagle e tutta la sua famiglia proprio OGGI ;|
    Però sembra che sia tutto risolto, anche se questo virus mi aveva quasi
    convinto a formattare tutto e “ricominciare una nuova vita”.
    Tanto ho tutti i backup su dvd, e magari finalmente davo una pulita al computer che sembra una discarica senza raccolta differenziata *___*

    Per me è un virus contro lo sfruttamento degli antivirus gratuiti…
    Qualche programmatore sottopagato che si sveglia male al mattino.

  4. Soveliss ha detto:

    Ciao a tutti,

    devo avere anche io lo stesso problema. A differenza vostra però non sono così esperto da capire cosa devo fare con il file che gentilmente ci è stato messo a disposizione. Potete darmi una drittina?

    Grazie

  5. redirete ha detto:

    Ciao Soveliss,
    Dopo che hai clickato sul link devi fare click su “Click here to start download..” selezioni dove vuoi salvare il file (es. desktop) poi controlli su desktop e apri il file .zip, estrai il contenuto. Doppio click sul file. click su “SI” click su “OK”, poi riavii, spero di aver risposto alla tua domanda. Ciao

  6. soveliss ha detto:

    Sì grazie,
    ha risposto alla mia domanda, ma purtroppo non è servito nulla … i servizi di helpnetbios e client dhcp restano ancora disabilitati 😦

  7. redirete ha detto:

    In questo caso prova nel seguente modo:
    Start–> Esegui –> scrivi ” services.msc ” –> Bottone OK
    Si aprirà il programma di gestione dei servizi di windowsXP
    Fai click con il tasto destro sui servizi che hai nominato e controlla che il tipo di avvio sia settato come automatico. Applica e Riavvia.

  8. soveliss ha detto:

    Purtroppo non ha funzionato, il netbios continua ad essere disattivato e di conseguenza anche il protocollo DHCP … 😦

  9. redirete ha detto:

    Sei sicuro di non avere ancora qualche tipo di virus? Posso consigliarti di fare una scansione di controllo. Mi pare strano.

  10. soveliss ha detto:

    Sono praticamente certo … farò unl’teriore scansione, ma sono monitorato da avast

  11. Graziano ha detto:

    Veramente tante grazie, con il tuo aiuto ora il mio portatile è tornato a vedere le reti WIFI, è veramente un solievo, sono rimasto in piedi fino a dopo l’una ieri sera a fare scansioni varie senza risolvere niente.
    Mi resta ancora un problema da risolvere, bagle mi ha mascosto la cartella “drivers” della cartella “system32”, non è che per caso hai una dritta anche per questo problema? Comunque ancora tante grazie e complimenti.

  12. redirete ha detto:

    Ciao Graziano, ho aggiornato il post, spero che tu risolva.

  13. Graziano ha detto:

    Grazie per l’aiuto ma non ho risolto. Ho provato ora a porre la questione in MegaLab e speriamo bene. Grazie comunque, sei un mito.

  14. Stefano ha detto:

    Ciao… 😦
    Ho nutrito l’illusione di essere riuscito nell’impresa, ma ahimè..
    Ho rimosso tutto tramite Ubuntu, messo tutte le voci possibili e immaginabili, installato un antivirus, ma mi mancano: centro sicurezza pc, windows defender (che ripristinerò) e dhcp client… Il problema è che ha direttamente cancellato questi servizi… Ho provato ad avviarli da services.msc, ma li dà come se non esistessero… Consigli?

  15. redirete ha detto:

    Da quello che dici non sembra neanche Bagle, o forse è una delle ultime varianti. Secondo me, la soluzione più veloce è un bel backup dei dati sensibili e una formattazione. Se non hai spazio creati una partizione per i files e poi reinstalli windows nell’altra (conta che poi non puoi riunire la partizione di sistema con quella creata). In bocca al lupo!
    p.s. Ma tutto questo ti è successo con vista o xp?

  16. Stefano ha detto:

    Purtroppo era Bagle… Colpa di questa cosa del DHCP ho dovuto formattare e mettere Xp (anche qui vari problemi legati alla politica Acer. vedremo..).
    Era Bagle, si, però non era quello standard…

  17. Roberto ha detto:

    NON HO PAROLE!!!! Grazie mille, per aver salvato me da PAZZIA certa ed il mio HD da formattazione SICURA!!!
    Ha funzionato alla perfezione ed immediatamente!

  18. tonykart ha detto:

    ciao a tutti

    innanzi tutto grazie per la chiave di registro del wifi!

    vorrei ricambiare con le chiavi di registro per risolvere il problema dei file nascosti.

    inserite in un file di testo normalissimo le seguenti righe e rinominate il file txt in .reg, poi doppio click ed unitelo al registro.

    // linee di codice rimosse dall’amministratore

    ciao a tutti

  19. redirete ha detto:

    ciao tonykart, ti ringrazio del codice ma lo avevo già linkato in un aggiornamento al post.

  20. Cristiano ha detto:

    Grazie sei stato molto in gamba ti sono obbligato.
    Eliminato il Bagle era rimasta la lesione al wi-fi.
    con il tuo .zip ho risolto.

    Ciao

  21. Piergiovanni ha detto:

    Redirete sei ufficialmente diventato il mio GURU informatico!!!
    GRAZIE per aver risolto questo fastidiosissimo casino del pc ^^
    solo una cosa…per eliminare DEFINITIVAMENTE sta cosa..cè un sistema? un antivirus o qualcosa…grazie!!!
    ciao

  22. redirete ha detto:

    Ciao Piergiovanni,
    definitivamente è una parolona, la procedura diciamo che è un ottima toppa, se vuoi la sicurezza al 100% formatta.
    Come antivirus Kaspersky è ottimo, puoi fare la scansione online su http://www.avp.it/virusscanner.html
    Conta che io non ho formattato e non ho sentito grandi differenze.
    In bocca al lupo 😉

  23. PollanetSquad ha detto:

    sei un mito grazie di esistere

    forse nel 2040 microsoft valuterà di inserire tra le pagine dei suoi manuali anche come risolvere in modo così semplce dei virus conosciuti già da un bel pò

    intanto graziegraziegrazie ci stavo tirando scemo

  24. Piergiovanni ha detto:

    Kaspersky Labs mettono a disposizione la loro ingegnieria per DEBELLARE questa peste…
    Dateci un occhiata
    http://www.vsantivirus.com/util-clrav.htm

    Che ne dite?Funzionerà?

  25. redirete ha detto:

    Tentare il tool di Kasper non nuoce di certo. Solo che non esisono software che riparano il registro al 100%, bisogna fare tutto a manina. Grazie per l’info Pier 😉

  26. marco ha detto:

    ciao volevo chiederti dove devo copiare il file delle reti wifi ke ho scaricato,mi spieghi la procedura passo per passo mi faresti un grande piacere.grazie

  27. redirete ha detto:

    Ciao Marco, è molto semplice.
    apri il file zip e fai doppio click sul file che c’è all’interno.
    Poi fai click su SI e su OK.
    Riavvi e dovrebbe rifunzionare il wifi.
    Se hai altri problemi non esitare a chiedere.
    Buona Giornata

  28. marco ha detto:

    ciao ti ringrazio per la velocità della risposta kmq nn ho risolto al riavvio continua a nn trovare la linea,ho pensato di cercare un nuovo cd di xp possibilmente senza virus e formattare…almeno ke tu nn abbia qualke idea.ti ringrazio lo stesso.

  29. redirete ha detto:

    Ciao Marco, qui trovi Xp professional SP3
    Masterizzalo e utilizza il tuo numero di serie originale.
    In bocca al lupo.

  30. Disc_nr ha detto:

    Ciao raga

    Io ho beccato la bestiaccia ma ho fatto una cosa banale per riuscire ad utilizzare i tool per la rimozione, tramite la console ho rinominato il file maledetto hldrrr.exe in hldrrr.old, nn so che versione ho preso fatto sta che nn ho altri .exe sospetti nella cartella drivers nascosta sotto windows/system32, faccio presente che prima nn mi partiva ne firefox ne ie e tanto meno i tool di rimozione ossia proframmi come gmer, avenger ecc ecc, ora parte scanan e logga che è un piacere, ho provato diversi remover e scan online ma nn mi rivelano più il virus, mi consigliate di fare tutto a manina o cos’altro….

    Grazie

    Disc

  31. redirete ha detto:

    Fare a manina cosa?
    Se gli antivirus non ti trovano virus, e tutto funziona.
    Direi che sei a posto.

  32. Davide ha detto:

    Ciao Redirete,
    anch’io ho beccato la bestiaccia (ma con Vista) debellata grazie alle tue indicazioni: mi ha però eliminato wireless zero configuration che non trovo più.
    Pensi che la tua procedura mi possa servireo vado ad aggiungere problemi?

  33. Vitale ha detto:

    Grazie infinite, sto problema me lo portavo dietro da molto tempo. Grazie, veramente!!!!

  34. redirete ha detto:

    @Davide
    Male che vada aggiungi delle chiavi inutilizzate.
    Io ora non ho tempo di farlo, però se hai un minimo di confidenza con il registro prova a cercare se le chiavi presenti nel file sono presenti in vista (questo prima di eseguirlo, altrimenti le trovi sicuro 🙂 se non ci sono cerca se esiste qualcosa di simile. In ogni caso verifica se in services.msc è il supporto wifi è settato come automatico.

    @Vitale Grazie anche a te di aver commentato. E’ sempre bello legere di qualcuno che si è tirato fuori dai problemi

  35. Francesco ha detto:

    Grazie, mi hai salvato dalla disperazione

  36. controguerra ha detto:

    Salve,
    ho avuto lo stesso problema su windows vista con service pack1.
    Sono riuscito a far ripartire tutto tranne il wi-fi.
    I file del registro che mettete a disposizione sono solo per XP, avete qualcosa per Vista?
    Grazie

  37. Antonio ha detto:

    Redirete,
    ho provato a far girare il file .reg contenuto nel file redirete.zip ed è andata bene. ho poi provato a far girare un antivirus (mcafee) che ha eliminato due file, ma al riavvio del computer era tornato tutto come prima (i.e. wifi bloccato, antivirus bloccati, avvio in modalità provvisoria bloccato).
    Ho riprovato a lanciare il file .reg ed ha funzionato nuovamente, ma non ho capito come pulire completamente il pc (con xp).
    PS non è più disponibile il file da te segnalato nascosti.rar. Credi sia questo il problema.
    Grazie.

  38. redirete ha detto:

    @controguerra, per i files nascosti ho aggiornato il link, c’è anche il file di registro per vista.

    @Antonio, Grazie per la segnalazione del link non funzionante.
    Se al riavvio hai molti problemi è possibile che il virus non sia stato rimosso, riverifica la procedura che ho segnalato nel post. Ti consiglio di provare kaspersky online.
    In bocca al lupo.

  39. marianna ha detto:

    ciao a tutti! ho trovato questa pagina mooooolto interessante, grazie mille per la dritta redirete! visto che sei così in gamba volevo esporti un altro problema… non so se sempre in seguito al maledetto bagle di cui sopra mi è scomparsa la periferica audio!!! please help me! 🙂 grazie mille

  40. redirete ha detto:

    Ciao Marianna.
    Fossi in te proverei a verificare che:
    1. La periferica audio sia attivata sul bios
    2. Rinstallare i driver di chipset e scheda audio

  41. marianna ha detto:

    ehm redirete… non capisco… 😦 se apro il volume mi dice solo: Nessuna periferica mixer è disponibile. Per installare periferiche mixer fare click su Stampanti e altro hardware in Pannello di controllo e quindi scegliere l’installazione hardware.
    Non posso ascoltare la radio, non si sentono i file in MP3 e non hanno audio nemmeno i video… il problema è che fino a ieri andava tutto bene… boooooooh! :-/

  42. alba ha detto:

    ciao Graziano,
    dopo giorni di sbattimento inutile sono riuscita a ripristinare la mia rete wifi con i tuoi suggerimenti.
    GRAZIE GRAZIE GRAZIE!!!
    Se sarò di nuovo nelle canne ti cercherò subito.
    ciao Alba

  43. redirete ha detto:

    ciao Alba,
    Graziano a scritto una guida di cui sono all’oscuro? 😀
    Spero tu abbia risolto.

    Ciao
    Redirete (Giorgio)

  44. deilsp ha detto:

    Grazie ragazzi avete risolto il mio problema. Non potevo stare senza il comodo WiFi che mi permetteva la classica “divanata ” con il PC in braccio

  45. redirete ha detto:

    HAHAHA, molto divertente FABBRONE!

  46. Gianniedp ha detto:

    Ciao redirete… SEI UN ‘MOSTRO’…
    Grazie mille, mi hai risolto un problema enorme.
    Mi potresti dare il link per la chiave di registro di vista?
    Grazie ancora

  47. Pingback: 10′000 VISITE! « Il blog di Redi

  48. redirete ha detto:

    ciao Gianniedp,
    ho aggiunto il file che molti stanno cercando.
    Fammi sapere se ha funzionato

  49. Gianniedp ha detto:

    Ciao Giorgio,

    ho scaricato il file ma nel momento in cui lo unzippo mi chiede la passwrod…

    ti ringrazio anticipatamente per la risposta….

    Ciao

  50. Bill Gheyz ha detto:

    Tnx a lot!!!

  51. redirete ha detto:

    @ Gianniedo
    Ho evidenziato la password che era segnalata all’interno del post.
    @Bill
    U R Welcome 😉

  52. Gianniedp ha detto:

    ok Grazie… visto il download si è oscurata la vista ahahahaha
    Ciao… ti farò sapere al + presto

  53. gianniedp ha detto:

    Ciao Giorgio,

    ho provato la tua chiave me purtroppo mi da errore.
    Dice che tento di ripristinare servizi gia attivi.
    Ho provato a remmare qualcosa ma niente da fare…
    Aspetto tue notizie, nel frattempo mica mi potresti linkare il download dell’ISO DI VISTA BUSINESS?
    Io ho un hp desk dove non mi hanno rilasciato il cd. Se volessi ripristinare il sistema operativo devo premere F11…
    Cosi facendo non posso reinstallere il sistema operativo.
    Ti Auguro Buona Notte.

  54. Edoardo ha detto:

    Ciao,
    grazie mille, stavo già per formattare! ho notato che comunque mi è rimasto un problema sul ripristino della connessione di rete wi-fi: mi dice che è impossibile completare il ripristino perchè non è possibile cancellare la cache ARP; pensi che possa dipendere dalle conseguenze di qualche Trijan anche dopo la rimozione?
    Ti prego, dammi qualche dritta!!
    ti benedico
    Edo.

  55. Gianniedp ha detto:

    Ciao Ragazzi,

    io sono ancora in cerca del della fix per Vista riguardante la WI-FI… 😦

    Buona Giornata a tutti

  56. Mimmo ha detto:

    Io Mi sono arreso…
    FORMATTO…

  57. peppepez ha detto:

    sei un genio!!!
    grande redirete… ho risolto tutto! NUMERO!!!

  58. peppepez ha detto:

    rieccomi…
    è sorto un nuovo problema!
    la procedura funziona ma la devo ripetere ogni volta che accendo il pc!!! dimentico io di salvare qualcosa oppure ho un altro problema?!?!
    grazie per l’attenzione

  59. Gianniedp ha detto:

    Ciao ragazzi,

    ho impiegato un po di tempo ma ho trovato la soluzione
    (su un sito meraviglioso) per i servizi wi-fi.
    Vi elenco la chiave che dovete aggiungere:
    ************************************************
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Ndisuio]
    “Start”=dword:00000003
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc]
    “UuidSequenceNumber”=dword:01bb08dc
    [HKEY_CURRENT_USER\SessionInformation]
    “ProgramCount”=dword:00000005
    ************************************************
    Dategli estenzione .reg e lanciate pure
    Vi ricordo che va bene Su Windows Vista…
    Quella per xp l’ha trovata il mitico REDIRETE…

    ORA MI RIMANE DA RISOLVERE LA DISATTIVAZIONE DELLE PROTEZIONI DEGLI ACCOUNT…

    BUONANOTTE A TUTTI

  60. peppepez ha detto:

    ho notato che avast continua a non girare più
    avete una soluzione anche per questo…
    sto impazzendo!non so più che fare…
    mi sa che a breve formatto

  61. flowerMan ha detto:

    ciao ragazzi,
    ho bisogno di una mano:
    sn riuscito grazie ad una guida e a 2 giorni di lavoro a debellare bagle sul mio Vista… ora però nn riesco, nonostante tutti i .reg possibili e immaginabili inseriti reperiti da qualsiasi parte, a ripristinare la connessione ad internet. La connessione va in “solo locale” sia wifi, sia via cavo.
    Inoltre quando vado su SERVICES.MSC non tutte le voci che mi dite di attivare le trovo nell’elenco…HELP!

  62. GIANNIEDP ha detto:

    Questa è la chiave per i servizi WIRELESS su Vista…
    Funizona perfettamente se si è eliminato bagle…
    Per eliminarlo segui alla lettera le istruzioni di REDIRETE…
    cIAOOOOOOOOOOOOOOOOOOOOO

    ********************************************

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Ndisuio]
    “Start”=dword:00000003
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc]
    “UuidSequenceNumber”=dword:01bb08dc
    [HKEY_CURRENT_USER\SessionInformation]
    “ProgramCount”=dword:00000005

    ***********************************************

  63. Gino ha detto:

    Grande gianniedp…
    6 un mito…
    adesso la mia wireless funziona perfettamente..

    Ciao

  64. francesco ha detto:

    Grazie!!! Mi hai salvato!!

  65. Annalisa ha detto:

    Grazie mille! Ero entrata in panico…ed invece, così breve e così veloce la tua soluzione! Kiss… 🙂

  66. sabrina ha detto:

    allora sono proprio sfigata io ho xp service pack 3 e ho scaricatoi file di redirete ma zero non riparte..il wirless è morto…x xp..perche con ubuntu funziona..ma a meserve che funzioni si xp home come diavolo devo fareeeeeeeeee aiutatemii:( uffaaaaaaaaa

  67. sabrina ha detto:

    funziona..miracolosamente senza toccare niente dall ultimo post messo..però l antivirus messenger e spy search and destroy.non partono..morti…che fare?

  68. redirete ha detto:

    Ciao Sabrina,
    ora che ti funziona la connessione prova a fare una scansione con kaspersky online (ripetere la procedura per intero non sarebbe male) e poi reinstalla antivirus spybot e messenger.
    In bocca al lupo 😉

  69. sabrina ha detto:

    ciao:( ascolta…non mi fa fare la scansione con kaspersky 😦 e non va nemmeno la periferica audio..devo avere qualche variente…:(

  70. sabrina ha detto:

    basta formatto non mi fa nstallare avast non mi fa installare messsenger questo virus è maledetto

  71. alberto ha detto:

    SANTO SUBITO. Dovrebbero farti santo. grazie risolto in 1 minuto

  72. redirete ha detto:

    @sabrina
    mi spiace, se hai già perso molto tempo, una formattazione sicuramente non te ne fa perdere altro.
    @alberto
    Dai, no! Santo è troppo! E poi il santo è deceduto in genere… azz…. tocco ferro, ma ho recepito il complimento 😉 Grazie, felice tu abbia risolto

  73. sabrina ha detto:

    MA xche loro hanno risolto e io no? io son riuscita risolveresolo il wi-fi..e cmq dovevo rifare laprocedura ogni volta che riaccendevoil pc! una variante?ho dovuto reinstalllare windows ed è sttao sufficente ..ora ho rimesso avast ma msn non c è verso..mi dice che non ho l aversione di installer aggiornat..vado nel sito microsoft x scaricarla..scarico..e non me lo fa installare..bah…

  74. redirete ha detto:

    Sabrina, prova a scaricare tutti gli aggiornamenti da http://windowsupdate.microsoft.com/ (sempre che la tua copia di windows sia autentica) e dopo averli installati tutti messenger dovrebbe funzionare… anche se mi sembra un problema insolito dopo una FORMATTAZIONE…

  75. Peppe mac ha detto:

    Grande gianniedp… questa fix è miticaaaaaaaaaaaaaaaaaaaaaa

  76. redirete ha detto:

    Ciao Peppe mac, il file che ho creato funziona?

  77. silvia ha detto:

    Ragazzi, vi ringrazio veramente tanto…ero andata in panico quando non mi funzionava più il wi-fi…
    grazie e ciao a tutti

  78. gianluca ha detto:

    ciao scusa ho un problema,prima ke sia troppo tardi,ho scaricato sia la fix per xp e la fix dei file nascosti,però malware mi trova sempre lo stesso virus in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srosa],come devo fare…nn me lo riesce a debellare…premettendo che sono un po’ ignorante di comp devo inserire qualche codice???grazie in anticipo

  79. redirete ha detto:

    Ciao Gianluca, hai provato a seguire la guida di hwupgrade che è segnalata nel post del blog?

  80. Roberto ha detto:

    WOW!!! Grazie mille sono giorni ch combattevo con questo problema e finalmente funziona

  81. Walter ha detto:

    Ciao a tutti, io ho avuto lo stesso problema vostro relativamente al wi-fi e fortunatamente ho risolto con il file.zip di re di rete, che ringrazio. Volevo sapere un’ultima cosa, a cui secondo me non si è data una precusa risposta: il wi-fi funziona, ma ogni volta che si accende il pc bisogna sempre aprire il programmino che ci hai dato, quello relativo al registro( si chiama fix wifi bagle by re di rete). Come posso evitare ogni volta di ripetere la procedura?grazie

  82. Nello ha detto:

    grazie sei un angelo

  83. redirete ha detto:

    @Walter
    Ciao, il file per il registro va utilizzato in seguito ad un attenta disinfezione del sistema (seguendo la guida). Se il sistema è pulito, ma non funziona la wifi si applica la fix e si riavvia. (la procedura basta per 1 volta).

    @Nello
    Prego

  84. mimmo ha detto:

    grazie
    magico fix wifi bagle by redirete.zip
    è bastato lanciarlo e ho risolto un problema
    di errore di connessione wireless
    che durava da mesi

    grazie mille

  85. Alessio ha detto:

    Ciao… ho fatto tutta la procedura scritta sulla guida per la rimozione del virus… antimalware mi ha trovato tutte le infezioni citate nella guida e me le ha rimosse (subito dopo il riavvio… ho anche il log). Successivamente non sono riuscito a far partire Combofix… cmq la rete mi funziona, ho messo a posto i registri con un paio di programmi (Registry Booster2, CCleaner), la scheda audio che prima non funzionava ora funziona e ho disinstallato NOD32 (il vecchio antivirus)… installandolo di nuovo non parte al riavvio e se lo spingo all’avvio manualmente mi dice che non è un’applicazione win32 valida… all’avvio mi apre la cartella di dominio di rete (ALESSIO per appunto… quella con ASPNET dentro) e non mi fa nemmeno installare ANTIVIR (nell’estrazione mi salta una dll… dice di riavviare e far ripartire il setup, ma nulla, non cambia niente…). Sapete darmi una mano… lo spero proprio… cmq a me pare che, nonostante nessun antivirus, il pc funziona bene… mi sembra difficile averlo ancora…
    Grazie

    • redirete ha detto:

      Ciao Alessio, il fatto che tu non riesca ad installare un antivirus non è un buonissimo segno, però potrebbe semplicemente essere un sintomo postumo del rootkit. Non posso fare a meno di consigliarti una miniprocedura per essere sicuro di averlo debellato (immagino tu abbia provato a riscaricare antivir per essere certo che non fosse corrotto l’installer):
      0 – Disattivare ripristino automatico di sistema
      1 – Scansione con Hijackthis (scarichi il programma in alto a dx, esegui la scansione, copi il log sul sito e vedi quali processi sono a rischio sicurezza, se alcuni lo sono, li etichetti con il programmino e gli dici di aggiustarli.
      2 – Scansione con Gmer, questo programmino è molto potente per rilevare dll/processi ecc caricati di nascosto.
      3 – Un colpo di Bagle Removal Tool non fà male, tanto è veloce
      4 – Kaspersky Online come scansione antivirus
      5 – Reinstallare Windows Installer (non è detto sia quello, puoi provare anche a farlo subito)
      6 – Se tutto è andato a buon fine, puoi procurarti una Chiave di licenza da 6 mesi per Avira Premium Security Suite QUI (ovviamente della suite puoi mettere solo l’antivirus se vuoi).

      Non vorrei essermi ripetuto eccessivamente nel consigliare scansioni e programmi, fammi sapere come va a finire. In bocca al lupo 😉

  86. Alessio ha detto:

    Grazie redirete… il fatto è che nemmeno mi parte hijackthis… applicazione win32 non valida… mi sparo??? 🙂

  87. Alessio ha detto:

    e cmq la scansione sul file che mi ha infettato l’avevo fatta… con nod32 aggiornato… sai ieri era venerdì 17… 🙂

  88. Alessio ha detto:

    e cmq altra cosa moooolto strana… ogni volta che riavvio mi dice che c’è qualche aggiornamento di win da fare… cosa starà succedendo???

  89. Alessio ha detto:

    cmq avevo provato a riscaricare l’installer di avira… ma nulla cambia… però problemi con CPU a 200 all’ora ad esempio non ne ho più… sarà forse un qualche rimasuglio??? devo ripetere la guida (quella nuova) del sito http://www.hwupgrade.it/forum/showthread.php?t=1933977 ??? grazie ancora….

  90. Anna ha detto:

    Grazie per i consigli. Stesso problema: antivirus fuori uso (Norton) e nessuna possibilità di reinstallarlo, programmi di sicurezza pc (tipo ccleaner etc) non funzionavano più, rete wireless scomparsa.
    Con la guida trovata in questa pagina http://www.hwupgrade.it/forum/showthread.php?t=1562611 ho rimosso il virus e grazie al tuo file fix wifi bagle by redirete.zip ora funziona di nuovo la rete wireless!
    Dopo giorni di ansia ora tutto ok!
    Grazie mille! ciao ciao

  91. Anna ha detto:

    Ah.. dimenticavo… anche a me dava continui aggiornamenti windows al riavvio del pc (nonostante il pc da giorni non fosse collegato a internet per problemi di rete)…

  92. Anna ha detto:

    PER REDIRETE:
    Scusa, visto che ci sono ti chiedo una cosa… Secondo te può avermi infettato anche chiavette o HD questo virus, se ci ho lavorato con quel pc nei giorni in cui il virus era ancora sul pc? Per ora dalle scansioni che ho fatto non mi dà niente… speriamo… ciao grazie

  93. redirete ha detto:

    Ciao Anna,
    fa sempre piacere leggere che qualcuno ha risolto il problema, per quanto riguarda le chiavette/hd, questo rootkit non dovrebbe propagarsi in questi dispositivi (almeno non nelle varianti che ho incontrato), se hai fatto una scansione antivirus puoi stare tranquilla.

  94. silvia ha detto:

    Anch’io dopo un bagle mi scervellavo per far funzionare la rete wifi… errore 1068 di zero configuration. ho scaricato il fix e riavviato, ora riesco a visualizzare le reti e si connette… stavo per cantar vittoria quando in realtà non si caricava proprio niente :/ ho provato più volte ma le pagine web non si aprono, non manda mail etc
    cheddevofà?

  95. redirete ha detto:

    ciao Silvia

    Potrebbe essere un problema del router impallato, hai provato a riavviarlo?

  96. silvia ha detto:

    si grazie, ma niente. via cavo funziona boh 😦

  97. relongobardo ha detto:

    redirete,un monumento!grazie xchè stavo per buttare dalla finestra il mio nuovo asus eeepc 1000 nuovo.e per fortuna che al mediaworld uno che sembrava la sapesse lunga mi ha detto che ero io che non sapevo farlo funzionare…..sto pirla

  98. memix ha detto:

    Ho seguito delle procedure trovate in rete.Ora l’antivirus riparte.Sto facendo una scansione completa del PC e per ora ha trovato alcuni virus.La domanda è: Quando l’antivirus riparte è sicuro che beagle è stato rimosso completamente?…in caso contrario c’è qualche altra cosa da fare?
    Per la cronaca ho fatto quello che dice questa procedura
    http://www.hwupgrade.it/forum/showthread.php?t=1562611

    Che dite voi mostri dell’informatica?

  99. DAduz ha detto:

    Grazie! Erano settimane che ci perdevo la testa!

  100. LucaG ha detto:

    Mitico! Tutto ok al primo colpo.

  101. Filippo ha detto:

    GRAZIEEEEEeeeEEEEee!!! Finalmente ho il wireless che Beagle mi ha annullato per un’anno e mezzo, andavo via Lan….:(
    OTTIMA la fix per il file di registro di win.
    Sei un GRANDE!!

  102. Alberto ha detto:

    Grazie del fix per il wifi in XP. Io ero stato infettato dal Bagle l’anno scorso e pensavo di averlo debellato ma da un po’ di tempo il mio portatile compaq non mi ostrava più le reti disponibili. Ora sempra tutto a posto.
    Grazie!

  103. PIETRO BORELLA ha detto:

    Senza possibilità di visualizzare reti wifi, del tutto inerme ho scarcato il tuo file di modifica registro e TUTTO FUNZIONA PERFETTAMENTE: GRAZIE GRAZIE GRAZIE

  104. Riccardo ha detto:

    Si si si, grazie mille. Quasi mi viene da piangere !! Ci sei riuscito, ho risolto il problema scaricando il fix, e riavviando il pc. Grazie, grazie di cuore !

  105. Francesco ha detto:

    Sono l’ultimo colpito dal maledetto bagle.
    Dopo averlo sterminato mi era rimasta fuori uso la wireless…grazie 1000 per l’aiuto!

  106. antonio ha detto:

    ho bisogno di aiuto ragazzi non riesco a connettere imiei PC in rete wirelesscon dlink dir 301/con cjhiavetta dw111.vi prego aiutatemi .grazie.

    • redirete ha detto:

      ciao Antonio, il fatto che tu “non riesca a connetterti” implica che vedi le reti, quindi probabilmente non è un problema relativo alla disattivazione del servizio wifi da parte del rootkit. Ti consiglio di aggiornare i driver e di essere più specifico:
      Che sistema operativo utilizzi?
      Su altre reti riesci a connetterti?
      Non riesci a conneterti oppure non riesci a navigare?
      Su quale passaggio della connessione ti si blocca, richiesta dell’ip?
      Prova eventualmente a collegarti via cavo al TUO router dlink e cambia le impostazioni relative alla cifratura (WPA2 WPA WEP) per vedere se cambia qualcosa. Fammi sapere.
      Redirete

  107. Luisa ha detto:

    Beh gente, che dire, saranno MESI che avevo rinunciato al wireless per colpa di quel virusaccio. Grazie infinite per il vostro file che mi ha ripristinato il tutto! Vi sarà eternamente debitrice.

  108. carmatore ha detto:

    redirecte,mi credi??? ti devo 3 di anni sofferenze!!! tempo fa il mio toshiba portatile fu infettato da un virus,credo fosse questo beagle,ora nn ricordo perchè è davvero passata un’eterità e con l’aiuto di un mio amcio riuscimmo a eliminare il virus facendo uso,mi ricordo,di avenger,gmar,poi di kadsperki ecc ecc…tuttavia credo che da allora il mio pc nn riusciva a connettersi alle wi-fi se nn a quella mia che avevo a casa,ovunque andavo non mi faceva vedere le reti disponibili e solo oggi ho capito che tutto questo era dovuto a quel virus…praticamente non mi si avviava zero configuration reti disponibili…oggi dopo tanto tempo mi sono impuntato a rifare delle ricerche sul problema e ho trovatoil tuo sito e te,grazie a quella chiave di registro wi-fi per xp sono tornato a vedere le reti disponibili,una cosa che ormai avevo dmenticato visto che all’avvio mi si connetteva direttamente al mio router senza chiedermi niente anche perchè sul router nn aveno protezioni…ti ringrazio tantissimo e ti volevo chiedere se secondo te nel mio pc dovrei ristabilire qualche altra chiave di registro che magari quel virus mi distrusse all’epoca.
    GRAZIE!

  109. forever ha detto:

    Magnifico….Grazieeeeeeeeeeee!

  110. alegt3 ha detto:

    davvero fantastico …………………. SEI DAVVERO UN GENIO GRAZIE TANTO!!!!!!!!!!!!!

  111. Pier ha detto:

    Grazie!!! Risolto annoso problema.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...